2016年4月9日土曜日

android studio 2.0がに更新(instant run設定も)

ついにandroid studio 2.0が正式リリースされたので、さっそくアップデートを実施。
といっても、android studioを起動したらアップデートあるとってメッセージがあるから特に考えずに進めるだけだけど。
で、ダウンロード、インストールが完了したら、設定引継ぎするか聞かれるんで、そこは「一番上」を選んでOKで引き継がれるからOK。

で終わりかと思ったら、追加のアップデート。こっちは、Android sdk側。
必要あるかな?っておもいつつとりあえずアップデート。

ここで終わりかと思えば、今度はGradle pluginのアップデート。まあ、自分で探しながらやるのに比べれば全然楽だからいいんだけど。
で、build.gradleが
classpath 'com.android.tools.build:gradle:2.0.0'
に自動的に書き変わって、これでOKかと思いきやなんかエラーが。。
・Error:Gradle version 2.10 is required. Current version is 2.4. If using the gradle wrapper, try editing the distributionUrl in D:\soft\AndroidStudio\アプリ名\gradle\wrapper\gradle-wrapper.properties to gradle-2.10-all.zip
Fix Gradle wrapper and re-import project Gradle settings

英検3級の実力ではよくわからん。
取り合ず、「Gradleのバージョン2.10が必要で、今は2.4だから、Gradleの、 distributionUrlを変更して。gradle-wrapper.propertiesのファイルを」って感じかだろうたぶん。
なので、gredle->wrapper->gradle-wrapper.propetiesファイルを開いて、
 #distributionUrl=https\://services.gradle.org/distributions/gradle-2.4-all.zip distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip
と書き直し。
※もともとは、上の2.4が使用されているので、#でコメント後。下の行を追加。
でgradle syncをして、再度buildしてみるとやっとbuildが完了。
やっと終わりと思いきや、またエラーが。。。
・Error running app:Instant Run requires 'Tools | Android | Enable ADB integration' to be enabled
英検3級の実力でry。
たぶん、上のメニューボタンの
・Tools->Android->Enable ADB integration
を選択しろってことかな。で、設定。
実行。。。。。。。。
おー。動いた動いた。
で、やっと2.0にアップデート終了デイいた。

0 件のコメント:

コメントを投稿